Requirements

 

Adobe Photoshop

All our templates require Adobe Photoshop.

We recommend you use Adobe Photoshop CS6, however most of our templates will work with versions Adobe Photoshop CS4 and higher.

You can download Adobe Photoshop from Adobe Creative Cloud.

 

Fonts

To create a unique design for each of our templates we use a varying range of fonts.

The fonts we use for our templates are 100% free.

A list of the required fonts for each of our templates can be found on the product page.

It is your responsibility to make sure you have the correct fonts installed.

Fonts are mandatory if you want to keep the same font in preview.

 

Stock Photos of people and models

It is important to understand that due to licensing restrictions we do not include the models in every template (both free and premium).

We do in most cases provide links for you to obtain your own copy of the images.

The model stocks and images of people that we use in our preview images are for preview purposes only and meant as an example for you so you can see what is possible to achieve when using our flyers.

We make using your own images easy and for the majority of our design templates all you need do is copy and paste your photograph to replace our predefined image placeholders.